Dasmikro (TBS Benedini clone)

Talk about all other types of electronics here, such as batteries!

Postby Max-U52 » Wed Jul 31, 2019 5:08 pm

wibblywobbly wrote:Well it should be pretty obvious who the Major North American Vendor is, seeing as there is only one...Luke should drop him a line. :clap:



North America can include Canada and Mexico so there are more than one major vendor over here.
User avatar
Max-U52
Lieutenant
 
Posts: 3212
Joined: Sat Sep 12, 2015 8:56 pm
Location: Detroit

Postby wibblywobbly » Wed Aug 28, 2019 9:20 pm

I ordered a Benedini Mini clone, about £30, and it arrived without problems. They come without any sounds installed, but luckily I have a USB lead that I was using on my DasMikro Micro clone. I have access to a Benedini soundset, so I loaded a Tiger soundset (572kb), set the parameters to 'Gas' and 'Autostart', plugged it into an RC Crawler that was sitting here...and it works perfectly.

Need to make it louder, but for the money, it's good. :thumbup:
User avatar
wibblywobbly
Major
 
Posts: 6240
Joined: Fri Oct 17, 2008 9:30 am
Location: South Wales Valley

Postby ModelMaker » Sat Oct 12, 2019 7:09 pm

I joined this forum solely because of this thread, so thanks to the OP! I am not an RC Tank builder, but I have been building RC scale ships and model conversions for a few years and have been looking for something like this module to enhance them.
This seems to be the only decipherable information for this board on the entire WWW. With this thread I have been able to order the board, order a programmer and install the programming software onto old netbook I had. I’m primarily a IOS guy, so going back to PC is challenging. I think I have everything?

Is it possible to work on the programming software without a board connected? Only asking as I’m waiting for stuff and wanted to get more familiar.

Anyways, I will be following intently as I have a lot to learn.
Thanks MM

ModelMaker
Recruit
 
Posts: 12
Joined: Sat Oct 12, 2019 6:47 pm

Postby Rad_Schuhart » Sat Oct 12, 2019 7:42 pm

ModelMaker wrote:I joined this forum solely because of this thread, so thanks to the OP! I am not an RC Tank builder, but I have been building RC scale ships and model conversions for a few years and have been looking for something like this module to enhance them.
This seems to be the only decipherable information for this board on the entire WWW. With this thread I have been able to order the board, order a programmer and install the programming software onto old netbook I had. I’m primarily a IOS guy, so going back to PC is challenging. I think I have everything?

Is it possible to work on the programming software without a board connected? Only asking as I’m waiting for stuff and wanted to get more familiar.

Anyways, I will be following intently as I have a lot to learn.
Thanks MM



Hi mate, welcome. I glad you liked the thread. In fact I am currently rewritting everything regarding the benedini products. I am splitting the info in three entries in my blog:
Review of the Benedini Mini
https://radindustries.wordpress.com/201 ... s-mini-v2/
Review of the Benedini micro:
https://radindustries.wordpress.com/201 ... -dasmikro/

And finally a step by step tutorial that I am currently writting, and I will publish in 2-3 weeks.

And yes, you can work with the software with no boards connected. Remember for the mini you need one software, and for the micro the other.
User avatar
Rad_Schuhart
Warrant Officer 2nd Class
 
Posts: 1449
Joined: Tue Jan 19, 2016 10:22 am
Location: Spanish living in Graz, Austria. Heart in UK.

Postby jarndice » Sat Oct 12, 2019 7:54 pm

Rad I have been telling you for ever that people do read your work and find it very helpful and now a Newbie has confirmed that so don't think of stopping please. :thumbup:
User avatar
jarndice
Major
 
Posts: 5510
Joined: Mon Sep 03, 2012 11:27 am
Location: the mountains of hertfordshire

Postby wibblywobbly » Sat Oct 12, 2019 8:14 pm

^^^ What he said! :D
User avatar
wibblywobbly
Major
 
Posts: 6240
Joined: Fri Oct 17, 2008 9:30 am
Location: South Wales Valley

Postby ModelMaker » Sat Oct 12, 2019 8:18 pm

Hi mate, welcome. I glad you liked the thread. In fact I am currently rewritting everything regarding the benedini products. I am splitting the info in three entries in my blog:
Review of the Benedini Mini
https://radindustries.wordpress.com/201 ... s-mini-v2/
Review of the Benedini micro:
https://radindustries.wordpress.com/201 ... -dasmikro/

And finally a step by step tutorial that I am currently writting, and I will publish in 2-3 weeks.

And yes, you can work with the software with no boards connected. Remember for the mini you need one software, and for the micro the other.[/quote]

Yeah, I managed to get the the software from banggood after much searching and reading about the whole counterfeiting thing. I have TBS-flash V1.0.1.4 correct?

Thanks! I have read just about everything I can, still processing. I look forward to reading future instalments of any kind. MM

ModelMaker
Recruit
 
Posts: 12
Joined: Sat Oct 12, 2019 6:47 pm

Postby ModelMaker » Sat Oct 12, 2019 8:20 pm

jarndice wrote:Rad I have been telling you for ever that people do read your work and find it very helpful and now a Newbie has confirmed that so don't think of stopping please. :thumbup:


Yes, this is very true! MM

ModelMaker
Recruit
 
Posts: 12
Joined: Sat Oct 12, 2019 6:47 pm

Postby Bobber Stu » Tue Oct 15, 2019 5:38 pm

I'll second that, this thread its why I joined the forum too.
Looking forward to the full blown tutorial....

Mean while I've ordered a Dasmikro micro and this USB adaptor: https://www.banggood.com/2Pcs-FT232RL-FTDI-USB-To-TTL-Serial-Converter-Adapter-For-Arduino-p-948294.html?rmmds=myorder&cur_warehouse=CN

Which driver do I need for the usb adaptor please? (win 10)

Bobber Stu
Recruit
 
Posts: 3
Joined: Sat Oct 12, 2019 6:56 pm

Postby machine » Sun Nov 10, 2019 11:42 pm

I had my das mikro working when it first arrived, but now all I get is modul did not answer.
I noticed that windows forced a driver update which is no longer supported, so I did a forced downgrade and still get modul did not answer.
So frustrating sometimes

Sent from my SM-G965U using Tapatalk
User avatar
machine
Lance Corporal
 
Posts: 174
Joined: Fri Jan 23, 2015 5:07 pm

Postby ModelMaker » Mon Nov 11, 2019 4:25 am

Would anybody be able to confirm for me that this is the correct driver for Win7. I can’t get this to connect. It all looks right, keep getting the “module did not answer”. I have COM4 selected, there was not an option to select a COM prior to the driver install so it seems that the Flash is recognizing it.
I’m stumped. I am running power through the ESC and the micro’s led is illuminated.
Thanks MM
Attachments
C421F736-D1A0-48D2-B979-287ACB769953.jpeg

ModelMaker
Recruit
 
Posts: 12
Joined: Sat Oct 12, 2019 6:47 pm

Postby Rad_Schuhart » Mon Nov 11, 2019 9:35 am

machine and ModelMaker,

it seems both of you are experimenting the same issue. I had no idea this was happening, so I have to try it myself and see what happens...

If it is as you say, probably Mr Benedini is going to need to update his software...
User avatar
Rad_Schuhart
Warrant Officer 2nd Class
 
Posts: 1449
Joined: Tue Jan 19, 2016 10:22 am
Location: Spanish living in Graz, Austria. Heart in UK.

Postby jhamm » Mon Nov 11, 2019 8:15 pm

Hi,
try the drivers from FTDI:
https://www.ftdichip.com/Drivers/VCP.htm
User avatar
jhamm
Lance Corporal
 
Posts: 237
Joined: Fri May 19, 2017 7:21 am

Postby ModelMaker » Mon Nov 11, 2019 9:01 pm

Rad_Schuhart wrote:machine and ModelMaker,

it seems both of you are experimenting the same issue. I had no idea this was happening, so I have to try it myself and see what happens...

If it is as you say, probably Mr Benedini is going to need to update his software...


I am using the files that were linked to Banggood, and not having access to the originals I have no idea if they are legit.
What I’m trying to grasp is if there is a specific driver required to connect with Flash or is this a generic driver that allows your computer to recognize the adapter?
I can use troubleshooting to let the computer find a driver, which it did. Or use the driver provided in the links, both drivers seem to give a perfect working feed back in the Devices menu.

ModelMaker
Recruit
 
Posts: 12
Joined: Sat Oct 12, 2019 6:47 pm

Postby Rad_Schuhart » Mon Nov 11, 2019 9:58 pm

ModelMaker wrote:
Rad_Schuhart wrote:machine and ModelMaker,

it seems both of you are experimenting the same issue. I had no idea this was happening, so I have to try it myself and see what happens...

If it is as you say, probably Mr Benedini is going to need to update his software...


I am using the files that were linked to Banggood, and not having access to the originals I have no idea if they are legit.
What I’m trying to grasp is if there is a specific driver required to connect with Flash or is this a generic driver that allows your computer to recognize the adapter?
I can use troubleshooting to let the computer find a driver, which it did. Or use the driver provided in the links, both drivers seem to give a perfect working feed back in the Devices menu.


The drivers in bangood were the same uploaded on the benedini site. Of course they are not legit... Anyway I dont think there is a specific driver. Try with the one in the link from Jhamm and tell us if it works.

Also check the connectors are fine and well connected. The pins in the micro are so tiny that they might be damaged.
User avatar
Rad_Schuhart
Warrant Officer 2nd Class
 
Posts: 1449
Joined: Tue Jan 19, 2016 10:22 am
Location: Spanish living in Graz, Austria. Heart in UK.

Postby ModelMaker » Mon Nov 11, 2019 11:01 pm

Rad_Schuhart wrote:
ModelMaker wrote:
Rad_Schuhart wrote:machine and ModelMaker,

it seems both of you are experimenting the same issue. I had no idea this was happening, so I have to try it myself and see what happens...

If it is as you say, probably Mr Benedini is going to need to update his software...


I am using the files that were linked to Banggood, and not having access to the originals I have no idea if they are legit.
What I’m trying to grasp is if there is a specific driver required to connect with Flash or is this a generic driver that allows your computer to recognize the adapter?
I can use troubleshooting to let the computer find a driver, which it did. Or use the driver provided in the links, both drivers seem to give a perfect working feed back in the Devices menu.


The drivers in bangood were the same uploaded on the benedini site. Of course they are not legit... Anyway I dont think there is a specific driver. Try with the one in the link from Jhamm and tell us if it works.

Also check the connectors are fine and well connected. The pins in the micro are so tiny that they might be damaged.


Yeah, just stumped. Connections have been checked twice.
Attachments
E6506E85-B9C1-4D22-8B37-EFA5B5E86533.jpeg
E6506E85-B9C1-4D22-8B37-EFA5B5E86533.jpeg (50.32 KiB) Viewed 124 times

ModelMaker
Recruit
 
Posts: 12
Joined: Sat Oct 12, 2019 6:47 pm

Postby ModelMaker » Tue Nov 12, 2019 8:31 am

Okay, I changed the USB cord and downloaded a different driver. Had to turn of the wifi to get the driver to load manually.
I now have connected and green bar. When I click read Param, should that show me the sound set that is pre-loaded ? It doesn’t seem to populate.
Thanks, MM
https://www.google.ca/amp/s/www.usb-drivers.org/ft232r-usb-uart-driver.html/amp

ModelMaker
Recruit
 
Posts: 12
Joined: Sat Oct 12, 2019 6:47 pm

Postby machine » Tue Nov 12, 2019 1:51 pm

ModelMaker wrote:Okay, I changed the USB cord and downloaded a different driver. Had to turn of the wifi to get the driver to load manually.
I now have connected and green bar. When I click read Param, should that show me the sound set that is pre-loaded ? It doesn’t seem to populate.
Thanks, MM
https://www.google.ca/amp/s/www.usb-drivers.org/ft232r-usb-uart-driver.html/amp
Which driver's did you use?

Sent from my SM-G965U using Tapatalk
User avatar
machine
Lance Corporal
 
Posts: 174
Joined: Fri Jan 23, 2015 5:07 pm

Postby Rad_Schuhart » Tue Nov 12, 2019 2:05 pm

ModelMaker wrote:Okay, I changed the USB cord and downloaded a different driver. Had to turn of the wifi to get the driver to load manually.
I now have connected and green bar. When I click read Param, should that show me the sound set that is pre-loaded ? It doesn’t seem to populate.
Thanks, MM
https://www.google.ca/amp/s/www.usb-drivers.org/ft232r-usb-uart-driver.html/amp


Nope, even when it is there, it never reads the sound set or individual sounds flashed.
If you want to see it, you need to reflash it.
User avatar
Rad_Schuhart
Warrant Officer 2nd Class
 
Posts: 1449
Joined: Tue Jan 19, 2016 10:22 am
Location: Spanish living in Graz, Austria. Heart in UK.

Postby ModelMaker » Tue Nov 12, 2019 5:21 pm

machine wrote:
ModelMaker wrote:Okay, I changed the USB cord and downloaded a different driver. Had to turn of the wifi to get the driver to load manually.
I now have connected and green bar. When I click read Param, should that show me the sound set that is pre-loaded ? It doesn’t seem to populate.
Thanks, MM
https://www.google.ca/amp/s/www.usb-drivers.org/ft232r-usb-uart-driver.html/amp
Which driver's did you use?

Sent from my SM-G965U using Tapatalk


Use the link that I added. I tried a few different ones, this one worked.
https://www.usb-drivers.org/ft232r-usb-uart-driver.html
Last edited by ModelMaker on Tue Nov 12, 2019 5:38 pm, edited 1 time in total.

ModelMaker
Recruit
 
Posts: 12
Joined: Sat Oct 12, 2019 6:47 pm

PreviousNext

Return to Other electronics

Who is online

Users browsing this forum: No registered users and 2 guests