Clark TK80 SPW main gun elevation servo

Discussion for Clark electronics

Postby dabber » Thu May 12, 2022 4:51 pm

Good evening all, just wonder if anyone can shed some light on my problem. Don't want to keep bothering Stian.

I have the above fitted to my 1:10 3d printed COMET. Now try as I may, I can't get the elevation servo to operate, am I missing something basic here. I have managed to get the recoil servo working out of the box, and also set the momentum with the Sony remote. Just wondering if I need to activate something within the basic setup system.

Thanks in advance, hope you can help.
Gary
User avatar
dabber
Lance Corporal
 
Posts: 102
Joined: Sat Jan 07, 2017 9:17 pm

Postby tankme » Thu May 12, 2022 6:13 pm

Yes, you need to activate on function page 2 by hitting the "-/--" key on the remote. Needs to be set to PWM (which is servo control) mode pressing "1" on the remote.

Image

tankme
Staff Sergeant
 
Posts: 941
Joined: Tue Oct 31, 2017 4:51 pm
Location: Elgin, TX

Postby Jarlath » Thu May 12, 2022 6:30 pm

With the a Flysky I6S TX and IA6B or IA10B RX's using an S-Bus Clark board... Even if setup to use SBus, the signals are still sent to the regular channels on the RX.

This option works well with a non-centering joystick, is to directly connect the elevation servo to the proper channel on the receiver. As it will leave your servo in the position that you leave the joystick (aka stay depressed or elevated position).

YMMV on other TX/RX combos...
User avatar
Jarlath
Corporal
 
Posts: 374
Joined: Mon Jun 27, 2016 2:45 pm
Location: Ontario, Canada

Postby dabber » Thu May 12, 2022 6:54 pm

Many thanks for the info, and your quick reply Tankme. Unfortunately, tried several times and it still didn’t seem to activate or work from the board.

Jarlath, on the other hand better news…I tried plugging into the RX, and bingo off she went. Just need to sort out the self centring stick now. Many thanks for your efforts to.

These boards are a wonderful piece of kit, very happy with my purchase.
User avatar
dabber
Lance Corporal
 
Posts: 102
Joined: Sat Jan 07, 2017 9:17 pm

Postby dabber » Thu May 12, 2022 7:12 pm

Ahhhhh, just noticed that the number "1" button on the remote maybe faulty, it appears to be sticking on the casing and not releasing fully. Possibly not registering a push, I'll try again at the weekend.

Thanks again fellas.
User avatar
dabber
Lance Corporal
 
Posts: 102
Joined: Sat Jan 07, 2017 9:17 pm

Postby dabber » Fri May 13, 2022 12:04 pm

Well as I thought the “1” button on the remote was sticking. Trimmed off the casing, and great news it worked, now elevation servo is on the TK80.

I require another TK80 board for new project shortly, maybe time to replace the remote at the same time. I've had it since the initial TK20 boards, many moons ago.

Thanks again for your help, it was invaluable.
User avatar
dabber
Lance Corporal
 
Posts: 102
Joined: Sat Jan 07, 2017 9:17 pm

Postby maxmekker » Fri May 13, 2022 12:05 pm

feel free to bother me dabber :thumbup: no problem at all
User avatar
maxmekker
Warrant Officer 1st Class
 
Posts: 1635
Joined: Tue Apr 27, 2010 8:47 am
Location: Norway

Postby dabber » Fri May 13, 2022 12:12 pm

Thats very kind, but I’ve already taken up to much of your valuable time.

I’ll be in touch shortly for another board, if I’m honest its only for the delicious chocolate though…
User avatar
dabber
Lance Corporal
 
Posts: 102
Joined: Sat Jan 07, 2017 9:17 pm


Return to Clark

Who is online

Users browsing this forum: No registered users and 1 guest